package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`h.*e.*l.*l.*o.* .*w.*o.*r.*l.*d`)
var str = `1h2e3l4l5o6 7w8o9r0l0d0`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}