package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(\/|[a-z\-\d])*`)
var str = `/
/news
/news/
/news/sport
/news/sport/
/news/sport/12234
/news/sport/12234/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}