$re = '/^(?:-.*\n){3}-((?:.*\n(?!-+ Forwarded message).*)*)/m';
$str = '-match one
-match two
-match three
-and a bunch of notes here, potentially with more than 1 line or newlines included
and there may be hyphens in this text as well
This is a - text
- match five
---------- Forwarded message ----------
From:....
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);