import Foundation
let pattern = #"^(?:-.*\n){3}-((?:.*\n(?!-+ Forwarded message).*)*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
-match one
-match two
-match three
-and a bunch of notes here, potentially with more than 1 line or newlines included
and there may be hyphens in this text as well
This is a - text
- match five
---------- Forwarded message ----------
From:....
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)