const regex = /(\d+)\D(\d+)\D/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)\\D(\\d+)\\D', 'gm')
const str = `381651651.7148949841%`;
const subst = `$1,$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);