$re = '/^CTR/m';
$str = 'CTRasdkljfhalksjdfhalksjdfhalskjhf
2f3232rjfkalkj23f2a523gap289gaCTR
23rCTRCTRs;flkjs;ldfjkCTR
CTR23dfhalskjhf
CTRasdkljfhalksjd234251dfhalskjhf
CTRasdkljf3623462346jdfhalskjhf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);