$re = '/(?!^hello.*?123)(^.*$)/m';
$str = 'hello123abc
helloa123abc
hello123aabc
helloa123aabc
hello1abc
hello23abc
helloaabc
helloabc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);