$re = '/(?:<br|div>)([\s\S]*?)(?=<br|div>)/';
$str = 'the text<br>
Text text text and mooore text...<br>
Text text text and mooore text...<br>
Text text text and mooore text...<br>
<div> some text </div>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);