import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\W*\\b(?!foobar).+?\\b\\W*";
final String string = "this should be highlighted, and\n"
+ "same with this. but any sentence\n"
+ "that has the word\n"
+ "foobar\n"
+ "shouldnt be, and same for any regular\n"
+ "sentence with foobar <-- like that\n"
+ "foobar beginning a sentence should invalidate\n"
+ "the entire sentence, same with at the end foobar\n"
+ "only foobar, and nothing else of the sentence\n"
+ "more words here more irrelevant stuff to highlight\n"
+ "and nothing of the key word\n"
+ "what about multiple foobar on the same foobar line?";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}