re = /((?:\[[^]]*\])+)/
str = 'This is my string [something: something] and the string is very pretty [something: something][a][b][c].'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end