package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?iU)__t\(\s*["'](.*)["']\s*\)`)
var str = `alert(__t( 'Mingi tekst') );
alert(__t("Mingi tekst") );
alert(__t( var_name ) );
__t('Mingi tekst')
function name() {
console.log(__t('sdfsdf'));
}
true ? __t( 'Mingi tekst' ) : __t( 'Teine tekst' );
$(el).html( __t( 'Tekst' ) + variable + '__t( 'Tekst' ) );
function( [ __t( 'tekst' ), __t( 'tekst2' ) ] );`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}