$re = '/__t\(\s*["\'](.*)["\']\s*\)/iU';
$str = 'alert(__t( \'Mingi tekst\') );
alert(__t("Mingi tekst") );
alert(__t( var_name ) );
__t(\'Mingi tekst\')
function name() {
console.log(__t(\'sdfsdf\'));
}
true ? __t( \'Mingi tekst\' ) : __t( \'Teine tekst\' );
$(el).html( __t( \'Tekst\' ) + variable + \'__t( \'Tekst\' ) );
function( [ __t( \'tekst\' ), __t( \'tekst2\' ) ] );';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);