$re = '/(--.+?(?=\s--|$))/m';
$str = '--keyphrase=dill och en boll --dill --action=echo "dill!" --provider=gum --notify
--dill="bill :adasdas';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);