re = /^.*(?:IpAddress(?!":"-)|WorkstationName)":"(?P<ipaddr>[^"]+)/m
str = '# IPADDR = 192.10.10.10
... "WorkstationName":"WS-8300E-007","IpAddress":"192.10.10.10" ...
# IPADDR = WS-8300E-007
... "WorkstationName":"WS-8300E-007","IpAddress":"-" ...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end