import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)\\['(?<object>[^']+)'.*?setPosASL\\s*(?<setPosASL>[^;]+).*? setVectorDirAndUp\\s*(?<VectorDirAndUp>[^;]+)(?s-)";
final String string = "_newObject = createVehicle ['Land_CncWall4_F', [11459.2,11330.3,-0.000549316], [], 0, 'CAN_COLLIDE'];\n"
+ "_newObject setPosASL [11459.4,11330.2,317.238];\n"
+ "_newObject setVectorDirAndUp [[0.790714,-0.612186,0], [0,0,1]];\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}