package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[1-9]|1[0-2])\s*-\s*(?:[1-9]|1[0-2])\s*/\s*2[01]\d{2}$`)
var str = `1-6/2011`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}