re = /^(?:[1-9]|1[0-2])\s*-\s*(?:[1-9]|1[0-2])\s*\/\s*2[01]\d{2}$/m
str = '1-6/2011'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end