re = /(?P<nom>^[\w\d]?)\/(?P<latfield>(?P<latflag>[NS])(?P<latval>\d{1,2}d[0-5]\d?(\.\d*)?))\/(?P<lonfield>(?P<lonflag>[EW])(?P<lonval>[01]?\d{1,2}d[0-5]\d?(\.\d*)?)$)/
str = 'X/N45d54.56/W110d51.045'
# Print the match result
str.match(re) do |match|
puts match.to_s
end