re = /^([a-fA-F0-9]{0,4}[:]){4,7}([a-fA-F0-9]{0,4})$/
str = '2001:0000:3238:DFE1:63:0000:0000:FEFB
2001:0000:3238:DFE1:363:0:0000:FEFB
2001:0000:3238:DFE1:63::FEFB
2001:0:3238:DFE1:63::FEFB'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end