import Foundation
let pattern = #"^([a-fA-F0-9]{0,4}[:]){4,7}([a-fA-F0-9]{0,4})$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
2001:0000:3238:DFE1:63:0000:0000:FEFB
2001:0000:3238:DFE1:363:0:0000:FEFB
2001:0000:3238:DFE1:63::FEFB
2001:0:3238:DFE1:63::FEFB
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)