using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:0?[0-9]|1[0-2])[\s:]?[0-5][0-9]\s?(?:[ap]m?)?|(?:[01][0-9]|2[0-3])[\s:]?[0-5][0-9]\s?(?:hr?)?)$";
string input = @"Valid Test Data:
123
0345
1:23
03:45
123 a
123 am
1 23a
3:45 Am
3 45 pM
0345 h
0345 Hr
0345hR
Invalid Test Data:
123rr
123mm
2345Rr
12:45rR
234mm
2:34 mm
23 54 mm";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}