import Foundation
let pattern = #",(?<host>\w+)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Feb 15 10:44:32 test01pano.xxxxxx.com 1,2018/02/15 10:44:32,012501001035,SYSTEM,general,0,2018/02/15 10:44:23,,general,,0,0,general,informational,"FqdnRefresh job enqueued. Enqueue time=2018/02/15 10:44:23. JobId=13221. . Type: Full",6498771941074183103,0x8000000000000000,0,0,0,0,,deast02fw"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)