$re = '/#(?<id>\w[\w\d]*_(?<number>\d+))/';
$str = '#as123df_1';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);