# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(@\{)\s*(\S+)\s*(?=})/$1$2/gmi;t' <<< "<div><b>@{ firstname } @{lastname}</b>,@{ gender }</div>"