#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)(@\{)\s*(\S+)\s*(?=})"
Local $sString = "<div><b>@{ firstname } @{lastname}</b>,@{ gender }</div>"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)