using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(@\{)\s*(\S+)\s*(?=})";
string substitution = @"$1$2";
string input = @"<div><b>@{ firstname } @{lastname}</b>,@{ gender }</div>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}