re = /(@\{)\s*(\S+)\s*(?=})/mi
str = '<div><b>@{ firstname } @{lastname}</b>,@{ gender }</div>'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result