$re = '/ABC_A_CommunityRollover_Autocreate_Community\.[0-9-]+\.out/m';
$str = 'ABC_A_CommunityRollover_Autocreate_Community.12345678-1.out ABC_A_CommunityRollover_Autocreate_Community.88345678-1.out ABC_A_CommunityRollover_Autocreate_Community.99945678-1.out';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);