$re = '/^[0][0-9]{9}/m';
$str = 'qqqqqqqqqq
1111111111
345fg42356
43573457356735
fdrdsvgrevfc
0687897498';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);