import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(0[1-9]|1[012])[\\\\\\/](0[1-9]|[12][0-9]|3[01])[\\\\\\/](19|20)\\d\\d";
final String string = "Cheesy Dibbles\\n\\n\\n12/31/2011\\n\\n0 Comments\\n\\nThe cheese is left unspoken.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}