import Foundation
let pattern = #"(0[1-9]|1[012])[\\\/](0[1-9]|[12][0-9]|3[01])[\\\/](19|20)\d\d"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Cheesy Dibbles\n\n\n12/31/2011\n\n0 Comments\n\nThe cheese is left unspoken."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}