use strict;
my $str = '{
aa:\'a \\\'a ab\',test:"ab",foo:"bar",
intervak:1,
array:[\'test\',"t\\"est",\'tet\\\'s\'],
\'test\':"test te\'t test"
}';
my $regex = qr/((?:\[|:|,)\s*)'((?:\\'|[^'])*?[^\\])?'(?=\s*(?:\]|}|,))/p;
my $subst = '$1"$2"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";