re = /((?:\[|:|,)\s*)'((?:\\'|[^'])*?[^\\])?'(?=\s*(?:\]|}|,))/
str = '{
aa:\'a \\\'a ab\',test:"ab",foo:"bar",
intervak:1,
array:[\'test\',"t\\"est",\'tet\\\'s\'],
\'test\':"test te\'t test"
}'
subst = '$1"$2"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result