import Foundation
let pattern = #"((?:\[|:|,)\s*)'((?:\\'|[^'])*?[^\\])?'(?=\s*(?:\]|}|,))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{
aa:'a \'a ab',test:"ab",foo:"bar",
intervak:1,
array:['test',"t\"est",'tet\'s'],
'test':"test te't test"
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"$2""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)