using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"http:\/\/www\.planetrugby\.com\/gallery\/story\/([0-9,_])*\.html$";
string input = @"http://www.planetrugby.com/gallery/story/0,25928,9825_9179877,00.html";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}