$re = '/a[^abc\n]*c/s';
$str = 'a zzz c
a zzz c --- b
a b c
a 000 a b c';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);