package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)a[^abc]*b[^ac]*c`)
var str = `a zzz c
a zzz c --- b
a b c
a 000 a b c`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}