re = /php-built-api\/v1\/([^\/]*)\/([^\/]*)\/?/
str = 'https://php-built.com/php-built-api/v1/post/update/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end