using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(P([1-9]|[1-9][0-9])(W|D|M|H)|PT([1-9]|[1-9][0-9])H)";
string input = @"P10M";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}