$re = '/(.*?)@(.*?)\.(.{2,3})/';
$str = 'scherer.daniel95@web.de
penis@web.de';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);