# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[A-Za-z0-9 ']*(?:(?:~~|&&)[A-Za-z0-9 ']*)*\K(?:[^A-Za-z0-9 ']|\z)//g;t' <<< "I like~~cake~too&&m~~~~u~~~~~ch&now.~~~gh
a~&a"