import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "reg(ular expression(s|)|ex(p|es|))";
final String string = "\n"
+ "Quick Start\n"
+ "Tutorial\n"
+ "Tools & Languages\n"
+ "Examples\n"
+ "Reference\n"
+ "Book Reviews\n"
+ "RegexBuddy Easily create and understand regular expressions today.\n"
+ "Compose and analyze regex patterns with RegexBuddy's easy-to-grasp regex blocks and intuitive regex tree, instead of or in combination with the traditional regex syntax. Developed by the author of this website, RegexBuddy makes learning and using regular expressions easier than ever. Get your own copy of RegexBuddy now\n"
+ "Literal Characters\n\n"
+ "The most basic regular expression consists of a single literal character, such as a. It matches the first occurrence of that character in the string. If the string is Jack is a boy, it matches the a after the J. The fact that this a is in the middle of the word does not matter to the regex engine. If it matters to you, you will need to tell that to the regex engine by using word boundaries. We will get to that later.\n\n"
+ "This regex can match the second a too. It only does so when you tell the regex engine to start searching through the string after the first match. In a text editor, you can do so by using its \"Find Next\" or \"Search Forward\" function. In a programming language, there is usually a separate function that you can call to continue searching through the string after the previous match.\n\n"
+ "Similarly, the regex cat matches cat in About cats and dogs. This regular expression consists of a series of three literal characters. This is like saying to the regex engine: find a c, immediately followed by an a, immediately followed by a t.\n\n"
+ "Note that regex engines are case sensitive by default. cat does not match Cat, unless you tell the regex engine to ignore differences in case.\n\n\n"
+ " \n"
+ "Special Characters\n\n"
+ "Because we want to do more than simply search for literal pieces of text, we need to reserve certain characters for special use. In the regex flavors discussed in this tutorial, there are 12 characters with special meanings: the backslash \\, the caret ^, the dollar sign $, the regex period or dot ., the vertical bar or pipe sregexymbol |, the question mark ?, the asterisk or star *, the plus sign +, the opening parenthesis (, the closing parenthesis ), and the opening square bracket [, the opening curly brace {, These special characters are often called \"metacharacters\".\n\n"
+ "If you want to use any of these characters as a literal in a regex, you need to escape them with a backslash. If you want to match 1+1=2, the correct regex is 1\\+1=2. Otherwise, the plus sign has a special meaning.\n\n"
+ "Note that 1+1=2, with the backslash omitted, is a valid regex. So you won't get an error message. But it doesn't match 1+1=2. It would match 111=2 in 123+111=234, due to the special meaning of the plus character.\n\n"
+ "If you forget to escape a special character where its use is not allowed, such as in +1, then you will get an error message.\n\n"
+ "Most regular expression flavors treat the brace { as a literal character, unless it is part of a repetition operator like a{1,3}. So you generally do not need to escape it with a backslash, though you can do so if you want. An exception to this rule is the Java, which requires all literal braces to be escaped.\n\n"
+ "All other characters should not be escaped with a backslash. That is because the backslash is also a special character. The backslash in combination with a literal character can create a regex token with a special meaning. E.g. \\d is a shorthand that matches a single digit from 0 to 9.\n\n"
+ "Escaping a single metacharacter with a backslash works in all regular expression flavors. Many flavors also support the \\Q…\\E escape sequence. All the characters between the \\Q and the \\E are interpreted as literal characters. E.g. \\Q*\\d+*\\E matches the literal text *\\d+*. The \\E may be omitted at the end of the regex, so \\Q*\\d+* is the same as \\Q*\\d+*\\E. This syntax is supported by the JGsoft engine, Perl, PCRE, PHP, Delphi, and Java, both inside and outside character classes. Java 4 and 5 have bugs that cause \\Q…\\E to misbehave, however, so you shouldn't use this syntax with Java.\n\n\n"
+ " \n"
+ "Special Characters and Programming Languages\n\n"
+ "If you are a programmer, you may be surprised that characters like the single quote and double quote are not special characters. That regexp is correct. When using a regular expression or grep tool like PowerGREP or the search function of a text editor like EditPad Pro, you reg should not escape or repeat the quote characters like you do in a programming language.\n\n"
+ "In your source code, you have to keep in mind which characters get special treatment inside strings by your programming language. That is because those characters are processed by the compiler, before the regex library sees the string. So the regex 1\\+1=2 must be written as \"1\\\\+1=2\" in C++ code. The C++ compiler turns the escaped backslash in the source code into a single backslash in the string that is passed on to the regex library. To match c:\\temp, you need to use the regex c:\\\\temp. As a string in C++ source code, this regex becomes \"c:\\\\\\\\temp\". Four backslashes to match a single one indeed.\n\n"
+ "See the tools and languages section of this website for more information on how to use regular expressions in various programming languages.\n\n\n"
+ " \n"
+ "Make a Donation\n\n"
+ "Did this website just save you a trip to the bookstore? Please make a donation to support this site, and you'll get a lifetime of advertisement-free access to this site! Credit cards, PayPal, and Bitcoin gladly accepted.\n\n"
+ "Page URL: http://www.regular-expressions.info/characters.html\n"
+ "Page last updated: 09 August 2013\n"
+ "Site last updated: 14 September 2015\n"
+ "Copyright © 2003-2015 Jan Goyvaerts. All rights reserved.\n"
+ " \n"
+ "Regex Tutorial\n"
+ "Introduction\n"
+ "Table of Contents\n"
+ "Special Characters\n"
+ "Non-Printable Characters\n"
+ "Regex Engine Internals\n"
+ "Character Classes\n"
+ "Character Class Subtraction\n"
+ "Character Class Intersection\n"
+ "Shorthand Character Classes\n"
+ "Dot\n"
+ "Anchors\n"
+ "Word Boundaries\n"
+ "Alternation\n"
+ "Optional Items\n"
+ "Repetition\n"
+ "Grouping & Capturing\n"
+ "Backreferences\n"
+ "Backreferences, part 2\n"
+ "Named Groups\n"
+ "Branch Reset Groups\n"
+ "Free-Spacing & Comments\n"
+ "Unicode\n"
+ "Mode Modifiers\n"
+ "Atomic Grouping\n"
+ "Possessive Quantifiers\n"
+ "Lookahead & Lookbehind\n"
+ "Lookaround, part 2\n"
+ "Keep Text out of The Match\n"
+ "Conditionals\n"
+ "Balancing Groups\n"
+ "Recursion\n"
+ "Subroutines\n"
+ "Recursion & Capturing\n"
+ "Recursion & Backreferences\n"
+ "Recursion & Backtracking\n"
+ "POSIX Bracket Expressions\n"
+ "Zero-Length Matches\n"
+ "Continuing Matches\n"
+ "More on This Site\n"
+ "Introduction\n"
+ "Regular Expressions Quick Start\n"
+ "Regular Expressions Tutorial\n"
+ "Replacement Strings Tutorial\n"
+ "Applications and Languages\n"
+ "Regular Expressions Examples\n"
+ "Regular Expressions Reference\n"
+ "Replacement Strings Reference\n"
+ "Book Reviews\n"
+ "Printable PDF\n"
+ "About This Site\n"
+ "RSS Feed & Blog\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}