const regex = /(?!\d*[ -]\d)[^\d][+-]?\d*([.,]\d*)?(?<!-)(?!\d*[ -]\d)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!\\d*[ -]\\d)[^\\d][+-]?\\d*([.,]\\d*)?(?<!-)(?!\\d*[ -]\\d)', 'gi')
const str = `23 34 56 78 90
23-34-56-78-90
23-34
23.2
+2.1
-3.3434
433,55`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}