$re = '/(?!\d*[ -]\d)[^\d][+-]?\d*([.,]\d*)?(?<!-)(?!\d*[ -]\d)/i';
$str = '23 34 56 78 90
23-34-56-78-90
23-34
23.2
+2.1
-3.3434
433,55';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);