const regex = /(String|int|char|boolean|double)\s+(?!(?:String|int|char|boolean|double)\b)[a-zA-Z]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(String|int|char|boolean|double)\\s+(?!(?:String|int|char|boolean|double)\\b)[a-zA-Z]+', 'g')
const str = `char myDog
char char
boolean IsitTrue
boolean char
int intro
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);