re = /(String|int|char|boolean|double)\s+(?!(?:String|int|char|boolean|double)\b)[a-zA-Z]+/
str = 'char myDog
char char
boolean IsitTrue
boolean char
int intro
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result