import Foundation
let pattern = #"(String|int|char|boolean|double)\s+(?!(?:String|int|char|boolean|double)\b)[a-zA-Z]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
char myDog
char char
boolean IsitTrue
boolean char
int intro
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)