const regex = /(?: *(\d+(?:,\d+)?) *(?:x|$)){3}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?: *(\\d+(?:,\\d+)?) *(?:x|$)){3}', 'gm')
const str = `200 x 90 x 14
90x200
200 x 90x20
60,4 x46,5 x 42,6
90x190,9`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}