import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Broadcast traffic on has exceeded the set boundary";
final String string = "Broadcast traffic on gi1/0/3 has exceeded the set boundary 1Kbits";
final String subst = "12";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}