// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"Broadcast traffic on has exceeded the set boundary").unwrap();
let string = "Broadcast traffic on gi1/0/3 has exceeded the set boundary 1Kbits";
let substitution = "12";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}